Constant recreation question

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Constant recreation question

Tom Johnson
I inherited a project which uses ddlutils to keep a database up schema up to date whenever the program is run.   I needed to add a table and add a foreign key relationship back to another table.  I made the appropriate changes in both the XML script and the database.   This seemed to work fine.  However, whenever I run the program it seems to drop the new table and the relation and re-create them, thus losing the data I had in these tables.  I do not see what is wrong, but it does seem it is only doing this for the new changes and not the rest of the tables in the database/script.

Any suggestions?


________________________________
Notice: The information contained in this email and any attachments is confidential and may be subject to copyright or other intellectual property protection. If you are not the intended recipient, you are not authorized to use or disclose this information, and we request that you notify us by reply mail or telephone and delete the original message from your mail system.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Constant recreation question

Kevin Carr
This type thing happened to me.  I would suggest doing a Create XML from
Database Schema, and diff against the XML you already have.

Mine turned out to be an IDENTITY, that was marked as required in the
Database, but was not in my XML file as required.  The database
automatically marked as required.  (Or something like this.  I can't
remember exactly, it has been a little while.)

On 08/01/2012 01:28 PM, Tom Johnson wrote:
> I inherited a project which uses ddlutils to keep a database up schema up to date whenever the program is run.   I needed to add a table and add a foreign key relationship back to another table.  I made the appropriate changes in both the XML script and the database.   This seemed to work fine.  However, whenever I run the program it seems to drop the new table and the relation and re-create them, thus losing the data I had in these tables.  I do not see what is wrong, but it does seem it is only doing this for the new changes and not the rest of the tables in the database/script.
>
> Any suggestions?
>
>
> ________________________________
> Notice: The information contained in this email and any attachments is confidential and may be subject to copyright or other intellectual property protection. If you are not the intended recipient, you are not authorized to use or disclose this information, and we request that you notify us by reply mail or telephone and delete the original message from your mail system.
>

Loading...