Derby update and C-JDBC

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Derby update and C-JDBC

Stephan Bardubitzki
Hi,

I'm using Cloudscape 10 for a while and switched now to derby. The jdbc
driver for both a currently not supporting update able ResultSets.
Version 10_1 beta made some progress in this case, but inserting rows is
still not supported.

I'm wondering whether the use of C-JDBC can solve this issue?

I also can't connect to my Cloudscape 10 database with Derby 10.1 beta,
error:

ERROR XJ040: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ040, SQLERRMC:
/home/bardu/Database/BSDataXJ040.CXCW00:10.010.1
betaXCW00.DFailed to start database '/home/bardu/Database/BSData', see
the next exception for details.Unsupported upgrade from '10.0' to '10.1
beta'.

Why is it so and is there a workaround?

Thanks in advance.

Stephan



Reply | Threaded
Open this post in threaded view
|

Re: Derby update and C-JDBC

Daniel John Debrunner
Stephan Bardubitzki wrote:

> Hi,
>
> I'm using Cloudscape 10 for a while and switched now to derby. The jdbc
> driver for both a currently not supporting update able ResultSets.
> Version 10_1 beta made some progress in this case, but inserting rows is
> still not supported.
>
> I'm wondering whether the use of C-JDBC can solve this issue?
>
> I also can't connect to my Cloudscape 10 database with Derby 10.1 beta,
> error:
>
> ERROR XJ040: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ040, SQLERRMC:
> /home/bardu/Database/BSDataXJ040.CXCW00:10.010.1
> betaXCW00.DFailed to start database '/home/bardu/Database/BSData', see
> the next exception for details.Unsupported upgrade from '10.0' to '10.1
> beta'.
>
> Why is it so and is there a workaround?

See

http://incubator.apache.org/derby/derby_downloads.html#Development+trunk


Dan.



Reply | Threaded
Open this post in threaded view
|

Re: Derby update and C-JDBC

Satheesh Bandaram
In reply to this post by Stephan Bardubitzki
While I can't help you with C-JDBC, I can suggest how to workaround connecting to Cloudscape 10 database using Derby 10.1 beta. Check this posting:

http://mail-archives.apache.org/mod_mbox/db-derby-dev/200504.mbox/%3c42694E55.5060500@...%3e

Do keep a backup of your database before you try this. Derby typically supports upgrating between released products only, so you would be able to upgrade from 10.0 to 10.1, once 10.1 is released. Database upgrade is achieved using 'upgrade=true' URL attribute.

Satheesh

Stephan Bardubitzki wrote:
Hi,

I'm using Cloudscape 10 for a while and switched now to derby. The jdbc
driver for both a currently not supporting update able ResultSets.
Version 10_1 beta made some progress in this case, but inserting rows is
still not supported.

I'm wondering whether the use of C-JDBC can solve this issue?

I also can't connect to my Cloudscape 10 database with Derby 10.1 beta,
error:

ERROR XJ040: DERBY SQL error: SQLCODE: -1, SQLSTATE: XJ040, SQLERRMC:
/home/bardu/Database/BSDataXJ040.CXCW00:10.010.1
betaXCW00.DFailed to start database '/home/bardu/Database/BSData', see
the next exception for details.Unsupported upgrade from '10.0' to '10.1
beta'.

Why is it so and is there a workaround?

Thanks in advance.

Stephan