heads-up: disruptive checkin

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

heads-up: disruptive checkin

Rick Hillegas-3
My latest checkin (1859158) changes the build so that it requires the
latest version of Ant (1.10.6). Please update your Ant version accordingly.

Apologies for the disruption,

-Rick

Reply | Threaded
Open this post in threaded view
|

Re: heads-up: disruptive checkin

Bryan Pendleton-3
Thanks for the heads-up, Rick.

Seems like this might be causing problems with our Jenkins builds,
which seem to be running Ant 1.10.5?

Do we need to ask infra if they can update Ant?

thanks,

bryan

On Sun, May 12, 2019 at 9:35 AM Rick Hillegas <[hidden email]> wrote:
>
> My latest checkin (1859158) changes the build so that it requires the
> latest version of Ant (1.10.6). Please update your Ant version accordingly.
>
> Apologies for the disruption,
>
> -Rick
>
Reply | Threaded
Open this post in threaded view
|

Re: heads-up: disruptive checkin

Rick Hillegas-3
On 5/14/19 5:51 PM, Bryan Pendleton wrote:
> Thanks for the heads-up, Rick.
>
> Seems like this might be causing problems with our Jenkins builds,
> which seem to be running Ant 1.10.5?
>
> Do we need to ask infra if they can update Ant?
Already done: https://issues.apache.org/jira/browse/INFRA-18367. INFRA
says that they just updated the Ant version, but that is not what the
Jenkins builds testify. Maybe it takes a while for this change to
percolate through the infrastructure.

>
> thanks,
>
> bryan
>
> On Sun, May 12, 2019 at 9:35 AM Rick Hillegas <[hidden email]> wrote:
>> My latest checkin (1859158) changes the build so that it requires the
>> latest version of Ant (1.10.6). Please update your Ant version accordingly.
>>
>> Apologies for the disruption,
>>
>> -Rick
>>

Reply | Threaded
Open this post in threaded view
|

Re: heads-up: disruptive checkin

Davide Grandi-2
In reply to this post by Bryan Pendleton-3
Maybe they'll discover that ant 1.10.5 is installed, unbeknown to
everyone, in their server.
And getexecuted before any other one put (as in "my" linux) on the path
tail.

I've just put the 1.10.6 in the PATH head and the build is ok .

I'll then look for who and when installed ant unbeknownst.

Best regards,

     Davide Grandi

On 15/05/2019 02:51, Bryan Pendleton wrote:

> Thanks for the heads-up, Rick.
>
> Seems like this might be causing problems with our Jenkins builds,
> which seem to be running Ant 1.10.5?
>
> Do we need to ask infra if they can update Ant?
>
> thanks,
>
> bryan
>
> On Sun, May 12, 2019 at 9:35 AM Rick Hillegas <[hidden email]> wrote:
>> My latest checkin (1859158) changes the build so that it requires the
>> latest version of Ant (1.10.6). Please update your Ant version accordingly.
>>
>> Apologies for the disruption,
>>
>> -Rick
> .

--
Ing. Davide Grandi
email  : [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: heads-up: disruptive checkin

Rick Hillegas-3
Thanks for that confirmation, Davide. It looks like the latest Jenkins
build succeeded, so I'm cautiously hopeful that the Ant version has been
updated across our Jenkins infrastructure.

On 5/15/19 6:56 AM, Davide Grandi wrote:

> Maybe they'll discover that ant 1.10.5 is installed, unbeknown to
> everyone, in their server.
> And getexecuted before any other one put (as in "my" linux) on the
> path tail.
>
> I've just put the 1.10.6 in the PATH head and the build is ok .
>
> I'll then look for who and when installed ant unbeknownst.
>
> Best regards,
>
>     Davide Grandi
>
> On 15/05/2019 02:51, Bryan Pendleton wrote:
>> Thanks for the heads-up, Rick.
>>
>> Seems like this might be causing problems with our Jenkins builds,
>> which seem to be running Ant 1.10.5?
>>
>> Do we need to ask infra if they can update Ant?
>>
>> thanks,
>>
>> bryan
>>
>> On Sun, May 12, 2019 at 9:35 AM Rick Hillegas
>> <[hidden email]> wrote:
>>> My latest checkin (1859158) changes the build so that it requires the
>>> latest version of Ant (1.10.6). Please update your Ant version
>>> accordingly.
>>>
>>> Apologies for the disruption,
>>>
>>> -Rick
>> .
>